Cisco AnyConnect VPN Client for macs upgraded

If you have upgraded your Mac to OS 10.9, you will need to upgrade the version of Cisco AnyConnect VPN Client to version 3.1.04.

The new version is available on AU Install.

Last Updated: November 20, 2013