Shiniest isn’t always best

When we upgraded one of our WordPress installed, suddenly our animations went haywire. We often rely on a JavaScript framework called jQuery, and the new WordPress version included jQuery 1.9.

Turns out jQuery 1.9 is so different from other versions of jQuery that it has its own upgrade guide, and our site was using something much older which worked just fine for it, but didn’t like the new code at all.

This upgrade was necessary for security reasons, but it’s a great reminder that upgrading just for the sake of upgrading isn’t always the best plan.

Read more